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ADOBE AFTER EFFECTS CC CLASSROOM IN A BOOK 1

Adobe After Effects CC provides a comprehensive set of 2D and 3D tools  

for compositing, animation, and effects that motion-graphics professionals, 

visual effects artists, web designers, and film and video professionals need.  

After Effects is widely used for digital post-production of film, video, DVD,  

and the web. You can composite layers in various ways, apply and combine 

sophisticated visual and audio effects, and animate both objects and effects.

About Classroom in a Book

Adobe After Effects CC Classroom in a Book is part of the official training  

series for Adobe graphics and publishing software, developed with the support  

of Adobe product experts. The lessons are designed to let you learn at your 

own pace. If you’re new to Adobe After Effects, you’ll learn the fundamental 

concepts and features you’ll need to master the program. And if you’ve been 

using Adobe After Effects for a while, you’ll find that Classroom in a Book 

teaches many advanced features, including tips and techniques for using the 

latest version.

Although each lesson provides step-by-step instructions for creating a specific 

project, there’s room for exploration and experimentation. You can follow the 

book from start to finish, or do only the lessons that match your interests and 

needs. Each lesson concludes with a review section summarizing what you’ve 

covered.

GETTING STARTED



2 GETTING STARTED

Prerequisites

Before beginning to use Adobe After Effects CC Classroom in a Book, make sure that 

your system is set up correctly and that you’ve installed the required software and 

hardware. You should have a working knowledge of your computer and operating sys-

tem. You should know how to use the mouse and standard menus and commands, 

and also how to open, save, and close files. If you need to review these techniques, 

see the printed or online documentation included with your Microsoft® Windows® 

or Apple® Mac® OS software.

To complete the lessons in this book, you’ll need to have both Adobe After Effects 

CC and Adobe Bridge CC installed.

Installing After Effects and Bridge

You must purchase the Adobe After Effects CC software separately. For system 

requirements and complete instructions on installing the software, visit  

www.adobe.com/support. Note that After Effects CC requires a 64-bit operating 

system and OpenGL 2.0 support. You must also have Apple QuickTime 7.6.6  

or later installed on your system.

Many of the lessons in this book use Adobe Bridge. After Effects and Bridge use 

separate installers. You must install these applications from Adobe Creative Cloud 

onto your hard disk. Follow the onscreen instructions.

Optimizing performance

Creating movies is memory-intensive work for a desktop computer. After Effects CC 

requires a minimum of 4GB of RAM. The more RAM that is available to After Effects, 

the faster the application will work for you. For information about optimizing 

memory, cache, and other settings for After Effects, see “Improve performance”  

in After Effects Help.

Restoring default preferences

The preferences files control the way the After Effects user interface appears on 

your screen. The instructions in this book assume that you see the default interface 

when they describe the appearance of tools, options, windows, panels, and so forth. 

Therefore, it’s a good idea to restore the default preferences, especially if you are 

new to After Effects.

http://www.adobe.com/support
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Each time you quit After Effects, the panel positions and certain command settings 

are recorded in the preferences files. To restore the original default settings, press 

Ctrl+Alt+Shift (Windows) or Command+Option+Shift (Mac OS) while starting 

After Effects. (After Effects creates new preferences files if they don’t already exist 

the next time you start the program.)

Restoring the default preferences can be especially helpful if someone has already 

customized After Effects on your computer. If your copy of After Effects hasn’t been 

used yet, these files won’t exist, so this procedure is unnecessary.

Important: If you want to save the current settings, you can rename a preferences 

file instead of deleting it. When you are ready to restore those settings, change the 

name back, and make sure that the file is located in the correct preferences folder.

1 Locate the After Effects preferences folder on your computer:

• For Windows: .../Users/<user name>/AppData/Roaming/Adobe/

AfterEffects/12.0.

• For Mac OS: .../Users/<user name>/Library/Preferences/Adobe/

After Effects/12.0 

2 Rename any preferences files you want to preserve, and then restart After Effects.

Accessing the Classroom in a Book files

The lessons in Adobe After Effects CC Classroom in a Book use specific source files, 

such as image files created in Adobe Photoshop® and Adobe Illustrator®, audio files, 

and prepared QuickTime movies. To complete the lessons in this book, you need  

to download the lesson files from peachpit.com. You can download the files for 

individual lessons, or download them all in a single file.

Your Account page is also where you’ll find any updates to the chapters or to the lesson 

files. Look on the Lesson & Update Files tab to access the most current content. 

To access the Classroom in a Book files, do the following:

1 On a Mac or PC, go to www.peachpit.com/redeem, and enter the code found  

at the back of your book. 

2 If you do not have a Peachpit.com account, create one when you’re prompted  

to do so.

3 Click the Lesson & Update Files tab on your Account page. This tab lists 

downloadable files.

4 Click the lesson file links to download them to your computer. 

5 Create a new folder on your hard disk, and name it Lessons. Then, drag the 

lesson files you downloaded into the Lessons folder on your hard disk.

� Note: In Mac OS 
10.7 and later, the user 
library folder is hidden 
by default. To see it, in 
the Finder, choose Go > 
Go To Folder. In the Go 
To Folder dialog box, 
type ~/Library, and 
then click Go.

� Note: As you 
complete each lesson, 
you will preserve the 
start files. In case you 
overwrite them, you can 
restore the original files 
by downloading the 
corresponding lesson 
files from your Account 
page at peachpit.com.

http://www.peachpit.com/redeem


4 GETTING STARTED

When you begin each lesson, you will navigate to the folder with that lesson 

number, where you will find all of the assets, sample movies, and other project  

files you need to complete the lesson.

If you have limited storage space on your computer, you can download each lesson 

folder individually as you need it, and delete it afterward if desired. You do not have  

to save any finished project if you don’t want to, or if you have limited hard disk space.

About copying the sample movies and projects

You will create and render one or more QuickTime movies in some lessons in this 

book. The files in the Sample_Movie folders are examples that you can use to see the 

end results of each lesson and to compare them with your own results. 

The files in the End_Project_File folders are samples of the completed project for 

each lesson. Use these files for reference if you want to compare your work in prog-

ress with the project files used to generate the sample movies. These end-project 

files vary in size from relatively small to a couple of megabytes, so you can either 

download them all now if you have ample storage space, or download just the end-

project file for each lesson as needed, and then delete it when you finish that lesson.

How to use these lessons

Each lesson in this book provides step-by-step instructions for creating one or more 

specific elements of a real-world project. The lessons build on each other in terms 

of concepts and skills, so the best way to learn from this book is to proceed through 

the lessons in sequential order. In this book, some techniques and processes are 

explained and described in detail only the first few times you perform them. 

Many aspects of the After Effects application can be controlled by multiple tech-

niques, such as a menu command, a button, dragging, and a keyboard shortcut. 

Only one or two of the methods are described in any given procedure, so that you 

can learn different ways of working even when the task is one you’ve done before.

The organization of the lessons is also design-oriented rather than feature-oriented. 

That means, for example, that you’ll work with layers and effects on real-world 

design projects over several lessons, rather than in just one lesson.
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Additional resources

Adobe After Effects CC Classroom in a Book is not meant to replace documentation 

that comes with the program or to be a comprehensive reference for every feature. 

Only the commands and options used in the lessons are explained in this book. 

For comprehensive information about program features and tutorials, refer to 

these resources:

• Adobe After Effects Help and Support: www.adobe.com/support/aftereffects  

is where you can find and browse Help and Support content on Adobe.com.

• Adobe Creative Cloud Learning: helpx.adobe.com/creative-cloud/tutorials.html 

provides inspiration, key techniques, cross-product workflows, and updates  

on new features. The Creative Cloud Learn page is available only to Creative 

Cloud members.

• Adobe Forums: forums.adobe.com lets you tap into peer-to-peer discussions, 

questions, and answers about Adobe products.

• Adobe TV: tv.adobe.com is an online video resource for expert instruction and 

inspiration about Adobe products, including a How To channel to get you started 

with your product.

• Adobe Design Center: www.adobe.com/designcenter offers thoughtful articles 

on design and design issues, a gallery showcasing the work of top-notch designers, 

tutorials, and more.

• Resources for educators: www.adobe.com/education and edex.adobe.com 

offer a treasure trove of information for instructors who teach classes on Adobe 

software. Find solutions for education at all levels, including free curricula that 

use an integrated approach to teaching Adobe software and can be used to 

prepare for the Adobe Certified Associate exams.

Also check out these useful links:

• Adobe Marketplace & Exchange: www.adobe.com/cfusion/exchange is a 

central resource for finding tools, services, extensions, code samples, and more 

to supplement and extend your Adobe products.

• Adobe After Effects CC product home page: www.adobe.com/products/

aftereffects

• Adobe Labs: labs.adobe.com gives you access to early builds of cutting-edge 

technology as well as forums where you can interact with both the Adobe 

development teams building that technology and other like-minded members  

of the community.

http://www.adobe.com/support/aftereffects
http://www.adobe.com/designcenter
http://www.adobe.com/education
http://www.adobe.com/cfusion/exchange
http://www.adobe.com/products/aftereffects
http://www.adobe.com/products/aftereffects
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Adobe certification

The Adobe training and certification programs are designed to help Adobe  

customers improve and promote their product-proficiency skills. There are  

four levels of certification:

• Adobe Certified Associate (ACA)

• Adobe Certified Expert (ACE)

• Adobe Certified Instructor (ACI)

• Adobe Authorized Training Center (AATC)

The Adobe Certified Associate (ACA) credential certifies that individuals have  

the entry-level skills to plan, design, build, and maintain effective communications 

using different forms of digital media.

The Adobe Certified Expert program is a way for expert users to upgrade their 

credentials. You can use Adobe certification as a catalyst for getting a raise, finding  

a job, or promoting your expertise. 

If you are an ACE-level instructor, the Adobe Certified Instructor program takes 

your skills to the next level and gives you access to a wide range of Adobe resources.

Adobe Authorized Training Centers offer instructor-led courses and training on 

Adobe products, employing only Adobe Certified Instructors. A directory of AATCs 

is available at partners.adobe.com.

For information on the Adobe Certified programs, visit www.adobe.com/support/

certification/main.html.

http://www.adobe.com/support/certification/main.html
http://www.adobe.com/support/certification/main.html
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WORKING WITH SHAPE LAYERS

Lesson overview

In this lesson, you’ll learn how to do the following:

• Create custom shapes.

• Customize a shape’s fill and stroke.

• Use path operations to transform shapes.

• Animate shapes.

• Repeat shapes. 

• Snap layers into alignment. 

• Explore design options with the Brainstorm feature.

• Add a Cartoon effect to a video layer for a distinctive look.

• Use an expression to animate properties in time with audio.

This lesson will take approximately an hour to complete. Download the 

Lesson04 project files from the Lesson & Update Files tab on your Account 

page at www.peachpit.com, if you haven’t already done so. As you work 

on this lesson, you’ll preserve the start files. If you need to restore the start 

files, download them from your Account page. 

4

http://www.peachpit.com
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Shape layers make it easy to create expressive 
backgrounds and intriguing results. You can animate 
shapes, apply animation presets, and add Repeaters 
to intensify their impact.

PROJECT:  DJ PROMO CLIP
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Getting started

Shape layers are created automatically when you draw a shape with any of the draw-

ing tools. You can customize and transform an individual shape or its entire layer to 

create interesting results. In this lesson, you will use shape layers to build a dynamic 

background for the introduction of a reality series called DJ Quad Master. You’ll 

also use the Cartoon effect to change the overall look of the video. This effect can be 

processor-intensive. You may choose to skip the Cartoon effect exercise; if you do, 

you’ll be able to finish the project, but it won’t match the sample movie. 

First, you’ll preview the final movie and set up the project.

1 Make sure the following files are in the AECC_CIB/Lessons/Lesson04 folder  

on your hard disk, or download them from your Account page at 

www.peachpit.com now:

• In the Assets folder: DJ.mov, gc_adobe_dj.mp3

• In the Sample_Movie folder: Lesson04.mov

2 Open and play the Lesson04.mov sample movie to see what you will create  

in this lesson. When you are done, quit QuickTime Player. You may delete this 

sample movie from your hard disk if you have limited storage space.

As you start After Effects, restore the default application settings. See “Restoring 

default preferences” on page 2. 

3 Start After Effects, and then immediately hold down Ctrl+Alt+Shift (Windows) 

or Command+Option+Shift (Mac OS) to restore default preferences settings. 

When prompted, click OK to delete your preferences.

4 Click Close to close the Welcome screen.

After Effects opens to display a blank, untitled project.

5 Choose File > Save As > Save As, and then navigate to the AECC_CIB/Lessons/

Lesson04/Finished_Project folder.

6 Name the project Lesson04_Finished.aep, and then click Save.

Creating the composition

Next, you’ll import the files you need and create the composition.

1 Double-click an empty area of the Project panel to open the Import File dialog box.

http://www.peachpit.com
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2 Navigate to the AECC_CIB/Lessons/Lesson04/Assets folder on your hard disk, 

Shift-click to select the DJ.mov and gc_adobe_dj.mp3 files, and then click Import 

or Open.

3 Choose File > New > New Folder  

to create a new folder in the  

Project panel. 

4 Name the folder Assets, press 

Enter or Return to accept the 

name, and then drag the footage 

items you imported into the  

Assets folder. Then expand the 

folder so you can see its contents.

5 Press Ctrl+N (Windows) or Command+N (Mac OS) to create a new composition.

6 In the Composition Settings dialog box, name the composition Shapes 

Background, select the NTSC DV preset, and set the Duration to 10:00.  

Then click OK.

After Effects opens the new composition in the Timeline and Composition panels.

� Tip: To specify 10 
seconds, type 10. in 
the Duration box. The 
period indicates that 
there are no units in 
that position. To specify 
10 minutes, type 10.. in 
the box.
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Adding a shape layer

One advantage of using a shape layer, rather than a solid layer, is that you can use 

the Fill option to create a linear or radial gradient. You’ll use the Rectangle tool  

to create a gradient background for the composition.

About shapes

After Effects includes five shape tools: Rectangle, Rounded Rectangle, Ellipse, 

Polygon, and Star. When you draw a shape directly in the Composition panel, After 

Effects adds a new shape layer to the composition. You can apply stroke and fill set-

tings to a shape, modify its path, and apply animation presets. Shape attributes are 

all represented in the Timeline panel, and you can animate each setting over time.

The same drawing tools can create both shapes and masks. Masks are applied to 

layers to hide or reveal areas of an image, while shapes have their own layers. When 

you select a drawing tool, you can specify whether the tool draws a shape or a mask.

Drawing a shape

You’ll begin by drawing the rectangle that will contain the gradient fill.

1 Select the Rectangle tool ( ).

2 Choose 50% from the Magnification Ratio pop-up menu at the bottom  

of the Composition panel so that you can see the entire composition.

3 Click just outside the upper left corner of the composition, and drag the tool  

to the area just outside the bottom right corner, so that a rectangle covers the 

entire composition. 
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The shape appears in the Composition panel, and After Effects adds a shape layer 

named Shape Layer 1 to the Timeline panel.

Applying a gradient fill

You can change the color of a shape by modifying its Fill settings in the Tools panel. 

Clicking the word Fill opens the Fill Options dialog box, where you can select the kind 

of fill, its blending mode, and its opacity. Clicking the Fill Color box opens the Adobe 

Color Picker if the fill is solid, or the Gradient Editor if the fill is a gradient.

1 Click the word Fill to open the Fill Options dialog box.

2 Select the Radial Gradient option ( ), and click OK.

3 Click the Fill Color box (next to the word Fill) to open the Gradient Editor. 

4 Select the white color stop (the left color stop below the gradient ramp),  

and select a light blue color. (We used R=100, G=185, B=240.)

5 Select the black color stop (the right color stop below the gradient ramp),  

and select a dark blue color. (We used R=10, G=25, B=150.)

6 Click OK to apply the new gradient colors.
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Modifying gradient settings

The gradient is a little small, and it falls off quickly. You’ll adjust the settings  

for the shape layer to expand the gradient.

1 In the Timeline panel, expand Shape Layer 1 > Contents > Rectangle 1 > 

Gradient Fill 1, if it isn’t already visible.

2 Change the Start Point to 0, 225 and the End Point to 0, 740. 

Now the gradient originates at the bottom of the screen and falls off near the top 

and edges of the composition.

3 Hide the Shape Layer 1 properties.

4 Select the layer name (Shape Layer 1), press Enter or Return, and type Background. 

Press Enter or Return again to accept the new layer name.

5 Click the Lock column ( ) for the 

Background layer so that you don’t 

accidentally select it.

Creating custom shapes

Though there are only five shape tools, you can modify the paths you draw to create 

a wide variety of shapes. The Polygon tool, in particular, gives you great flexibility. 

You’ll use it to create rotating sun shapes in the background.
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Drawing a polygon

By default, the Polygon tool draws a shape using the settings of the last shape 

drawn with that tool. However, by adjusting the points, position, rotation, outer 

radius, outer roundness, and other values, you can dramatically alter the initial 

shape. You’ll modify a simple polygon to create a much more interesting shape.

1 Select the Polygon tool ( ), which is hidden behind the Rectangle tool ( ). 

2 Drag a polygon shape in the Composition panel. 

3 In the Timeline panel, expand Shape Layer 1 > Contents > Polystar 1 > Polystar 

Path 1.

4 Change the Points to 6, the Rotation to 0 degrees, and the Outer Radius to 150.

5 Change the Outer Roundness to −500%. 

6 Hide the Polystar Path 1 properties.

� Tip: While you’re 
dragging the shape,  
you can press the 
spacebar to reposition 
the shape in the 
Composition panel. 

� Tip: You can change 
settings to values below 
0 and above 100% for 
more dramatic results.
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7 Click the word Fill in the Tools panel to open the Fill Options dialog box. Select 

the Solid Color icon ( ), and then click OK.

8 Click the Fill Color box, and select a bright yellow. (We used R= 250, G=250, 

B=0.) Click OK.

9 Click the Stroke Color box, and select a bright gray. (We used R=230, G=230, 

B=230.) Click OK.

10  Change the Stroke Width in the Tools panel to 5 pixels to emphasize the stroke.

Twisting a shape

The Twist path operation rotates a path more sharply in the center than at the edges. 

Positive values twist clockwise; negative values twist counterclockwise. You’ll use 

the Twist path operation to give the shape a little more definition. 

1 In the Timeline panel, open the Add pop-up menu next to Contents in the Shape 

Layer 1 layer, and choose Twist.
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2 Expand Twist 1.

3 Change the Angle to 160.

4 Hide the Polystar 1 properties.

5 Choose File > Save to save your work so far.

Repeating a shape

You’ve created the basic shape, but you need many copies of it to fill the composi-

tion. You could duplicate the shape manually, but instead, you’ll use the Repeater 

path operation to create multiple rows of suns.

1 Select Shape Layer 1. 

You’re selecting the layer because you want to add the Repeater to the entire shape 

group, not just an individual shape.

2 Open the Add pop-up menu, and then choose Repeater. 

3 Expand Repeater 1.

4 Change the number of copies to 5. 

The Repeater creates four copies of the shape, overlapping each other. You’ll sepa-

rate them next.

5 Expand Transform: Repeater 1. 

6 Change the Position to 345,0. The first value represents the x axis. To move the 

shapes closer together, use a smaller value for the x axis; to move them farther 

apart, use a larger value.

� Note: There are 
multiple Transform 
properties in the 
Timeline panel, 
applying to different 
path operators. Make 
sure you’re selecting  
the appropriate 
Transform property for 
the object or layer you 
want to affect. In this 
case, you want to affect 
only the Repeater.
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Now the shapes are farther apart. But you can’t see them all at the same time.  

To move all of the shapes, you need to move the entire shape layer.

7 Hide the Transform: Repeater 1 properties.

8 Select Shape Layer 1, and then press P to display the Position property for the 

layer. Change the Position to −50, 65. 

The shape layer is now in the upper left corner of the composition. You’ll scale the 

layer and then add more rows.

9 Select Shape Layer 1, and then press S to display the Scale property for the layer. 

Change the Scale value to 50%. 

10  Press S to hide the Scale property for the layer.

11  Expand Shape Layer 1 > Contents.

12  Select Shape Layer 1, and then choose Repeater from the Add pop-up menu.

13  Expand Repeater 2 > Transform: Repeater 2.

14  Change the Position to 0, 385 so that there is vertical space between the rows.

15  Hide the Repeater 2 properties.

� Note: Because the 
horizontal and vertical 
values are linked, both 
values change when 
you change one.
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Rotating shapes

The suns should rotate on the background. You’ll animate the Rotation property  

for the original shape; changes will automatically apply to the duplicated shapes. 

1 In the Timeline panel, expand Shape Layer 1 > Contents > Polystar 1 > 

Transform: Polystar 1.

2 Press the Home key or drag the current-time indicator to the beginning  

of the timeline.

3 Click the stopwatch ( ) next to the Rotation property to create an initial 

keyframe for the layer.

4 Press the End key, or drag the current-time indicator to the end of the timeline.

5 Change the Rotation to 3x+0 degrees. This setting causes the shape to rotate 

three times in 10 seconds.

6 Hide the properties for Shape Layer 1.

7 Drag the current-time indicator across the timeline to preview the rotation.

Blending shapes with the background

The rotating suns look good, but they contrast with the background too much.  

You want the character in the main video file to be the focus of attention. You’ll 

change the blending mode and opacity for the shape layer to make the background 

more subtle.
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1 Click Toggle Switches/Modes at the bottom of the Timeline panel.

2 Choose Overlay from the Mode pop-up menu for the Shape Layer 1 layer.

3 Select Shape Layer 1, and then press T to display the Opacity property for  

the layer.

4 Change the Opacity value to 25%.

5 Press T to hide the Opacity property.

6 Select Shape Layer 1, press Enter or Return, and type Suns for the layer name. 

Press Enter or Return again to accept the new name.

7 Lock the layer to prevent accidental changes to it.

Creating stars

The Star tool is similar to the Polygon tool. A polygon is simply a star without an 

Inner Radius or Inner Roundness property; both tools create shapes called poly-

stars. You’ll use the Star tool to draw a star for the background, and then use the 

Pucker & Bloat operation to change the star’s shape. Then you’ll duplicate the star 

and rotate the stars around the layer’s anchor point.

Drawing a star

The Star tool is grouped with the other shape tools. To draw a star, drag the Star 

tool in the Composition panel.

� Note: Instead of 
changing the opacity 
for the entire layer, 
you could change the 
opacity for the original 
shape. The value 
would apply to all the 
duplicates as well.
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1 Select the Star tool ( ), which is hidden beneath the Polygon tool ( ).

2 Change the fill and stroke settings for the shape before you draw the star:

• Click the Fill Color box, and select a medium blue. (We used R=75, G=120, 

B=200.) Then click OK.

• Click the word Stroke, and click None ( ) in the Stroke Options dialog box. 

Click OK.

3 Draw a star near the center of the composition. After Effects adds a shape layer 

named Shape Layer 1 to the Timeline panel. 

4 In the Timeline panel, expand Shape Layer 1 > Contents > Polystar 1 > Polystar 

Path 1.

5 Change the Points to 6 and the Rotation to 150 degrees.

6 Change the Inner Radius to 50 and the Outer Radius to 90. The radius values 

change the shape of the star.

7 Expand the Transform: Polystar 1 properties.

8 Change the Position to −180, −70.

9 Collapse the Polystar 1 properties to hide them.

Applying Pucker & Bloat

After Effects includes a powerful path operation called Pucker & Bloat. You can 

pucker a shape by pulling the path’s vertices outward while curving segments 

inward, or bloat a shape by pulling the vertices inward while curving segments 

outward. Negative values pucker a shape; positive values bloat it. You’ll pucker the 

star to give it a distinctive look.

1 Select Shape Layer 1.

2 Choose Pucker & Bloat from the Add pop-up menu. 

� Note: If you have 
trouble seeing the 
star in front of the 
background, you can 
temporarily hide the 
Suns and Background 
layers by clicking the 
Video switches (eye 
icons) for the layers in 
the Timeline panel. 
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3 Expand Pucker & Bloat 1. 

4 Change the Amount to −125 to pucker the star.

This star shape will go well in the background. Now you can duplicate and  

animate it.

Duplicating shapes

You want to have multiple stars in slightly different sizes rotating around the 

screen. You’ll use the Repeater path operation again, but this time you’ll modify  

the Transform properties for the Repeater to get different results. 

1 Select Shape Layer 1, and choose Repeater from the Add pop-up menu.

2 Expand Repeater 1, and change the number of copies to 6.

Now there are six stars on the screen.

3 Expand Transform: Repeater 1. 

4 Change the Position to 0, 0 and the Rotation to 230 degrees.

Because you applied the rotation to the Repeater, rather than the shape, each star 

rotates around the layer’s anchor point to a different degree. When you change the 

Transform properties for the Repeater, the change is multiplied by the number of cop-

ies created. For example, if there are 10 copies of a shape and you change the Rotation 

value to 10 degrees, the first shape retains the original value of 0, the second shape 

rotates 10 degrees, the third shape rotates 20 degrees, and so on. The same concept 

applies to each of the Transform properties.
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In this project, the anchor point for the layer differs from the position of the shapes, 

so the chain of stars begins to wrap in on itself. 

5 Change the End Opacity to 65%. Each star is more transparent than the one  

before it.

6 Hide the Repeater 1 properties.

7 Select the Shape Layer 1 layer, and choose Repeater from the Add pop-up menu 

again to add another Repeater.

8 Expand Repeater 2 > Transform: Repeater 2.

9 Change the Position to −140, 0 and the Rotation to 40 degrees.

10  Change the Scale to 80%.

Each duplicate star will be smaller than the one before it. Because there are three 

duplicates of the first group of stars, some will be 64% the size of the original.

11  Change the End Opacity to 0%.

12  Collapse the Repeater 2 properties to hide them.

13 Choose File > Save.

Rotating shapes

You’ve rotated the stars around the anchor point for the layer. Now you want  

to animate each star to rotate around its own axis. To achieve this, you’ll animate 

the Rotation property for the polystar shape itself, not the layer or the Repeater.

1 Expand Polystar 1 > Transform: Polystar 1. 

2 Press the Home key or drag the current-time indicator to the beginning  

of the timeline.

3 Click the stopwatch icon ( ) for the Rotation property to create an initial 

keyframe.

4 Press the End key, or drag the current-time indicator to the end of the timeline.



106 LESSON 4 Working with Shape Layers

5 Change the Rotation to 180 degrees.

6 Manually preview the composition by dragging the current-time indicator along 

the timeline. After you confirm that everything is rotating, collapse the layer.

7 Rename the Shape Layer 1 layer Stars, and press Enter or Return to accept the 

layer name.

8 Lock the Stars layer.

Positioning layers with snapping

The rotating suns and stars are a good start. Now you’ll add a checkerboard pattern 

to the mix using solid-color layers. Positioning the layers will be easy with the snap-

ping feature in After Effects. You’ll create a new composition and nest it within the 

main composition. 

Creating a new composition

This checkerboard background includes multiple layers, so you’ll create a new com-

position for it.

1 Press Ctrl+N (Windows) or Command+N (Mac OS) to create a new composition.
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2 In the Composition Setting dialog box, name the composition Checkerboard, 

choose NTSC DV from the Preset menu, and type 10:00 for Duration. Then 

click OK.

After Effects open the new Checkerboard composition in the Timeline and 

Composition panels. You’ll start by adding two solid layers, the building blocks  

of the checkerboard background.

3 Choose Layer > New > Solid to create a solid layer.

4 In the Solid Settings dialog 

box, do the following, and 

then click OK:

• Name the layer Dark 

Blue.

• Change both the Width 

and Height to 100 px.

• Choose Square Pixels 

from the Pixel Aspect 

Ratio menu.

• Select a dark blue color. 

(We used R=25, G=50, 

B=150.) 
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5 With the Dark Blue layer selected in the Timeline panel, press R to display  

the Rotation property for the layer. Then change the Rotation to 45 degrees.

6 Select the Selection tool. Then, in the Composition panel, drag the layer  

up so that only the bottom half of the diamond appears in the composition. 

7 Press Ctrl+Y (Windows) or Command+Y (Mac OS) to create another solid layer.

8 In the Solid Settings dialog 

box, name the layer Light 

Blue, and change the color 

to a light blue (we used 

R=70, G=100, B=230).  

Then click OK.

The default width and height 

for a new solid layer match the 

settings you used previously, 

so the Light Blue layer has the 

same dimensions as the Dark 

Blue layer.

9 With the Light Blue layer selected in the Timeline panel, press R to display  

the Rotation property. Then change the Rotation to 45 degrees.
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Snapping layers into position

You’ve created two layers, but they have no relationship to each other in  

the composition. You’ll use the Snapping option in After Effects to quickly align  

the layers. When the Snapping option is enabled, the layer feature that is closest  

to your pointer when you click becomes the snapping feature. As you drag the layer 

near other layers, features on other layers are highlighted, showing you where the 

snapping feature would snap if you released the mouse button. 

1 Select Snapping in the options section of the Tools panel, if it’s not already 

selected.

2 Using the Selection tool ( ), select the Light Blue layer in the Composition 

panel.

When you select a layer in the Composition panel, After Effects displays the layer 

handles and anchor point. You can use any of these points as the snapping feature 

for a layer. 

3 Click near the corner handle on the left side of the Light Blue layer, and drag  

it near the lower right edge of the Dark Blue layer until it snaps into place, with 

the sides abutted. Be careful not to drag the corner itself, or you’ll resize the layer.

As you drag the layer, a box appears around the left corner handle you selected, 

indicating that it is the snapping feature. 

4 In the Timeline panel, select both of the layers, and press R to hide the Rotation 

property for both layers.

5 With both layers still selected, choose Edit > Duplicate to copy them.

� Note: You’re 
snapping solid-color 
layers in this exercise, 
which works well, but 
you cannot snap shape 
layers. Also, a layer must 
be visible to snap to it. 
2D layers can snap to 
2D layers, and 3D layers 
can snap to 3D layers. 

� Tip: If the Snapping 
option isn’t selected, 
you can temporarily 
enable it by holding 
down the Control key 
(Windows) or Command 
key (Mac OS) as you 
click and drag a layer.

� Tip: Instead  
of choosing Edit > 
Duplicate, you can  
press Ctrl+D (Windows) 
or Command+D (Mac 
OS) to duplicate layers.
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6 In the Composition panel, drag the two new layers down to the left, and then 

down to the right, so that the new Dark Blue layer abuts the original Light Blue 

layer. Remember that the snapping feature is determined by where you initially 

click when you begin to drag.

7 Repeat steps 5–6 twice, so that you have a column of diamonds filling the screen.

8 Choose Edit > Select All to select the layers in the Timeline panel.

9 Press Ctrl+D (Windows) or Command+D (Mac OS) to duplicate the layers. Then 

move them to the left in the Composition panel until they snap into place.

10 Repeat step 9 until the the Composition panel is full. Pull the duplicate layers  

to the left or right as necessary. Remember to click near an appropriate snapping 

feature as you begin dragging each time.

Nesting the composition

Now that the Checkerboard composition is complete, you’ll nest it inside the main 

composition. To blend the checkerboard with the rest of the background, you’ll 

change its blending mode, too.

1 Select the Shapes Background tab in the Timeline panel.

2 Drag the Checkerboard composition from the Project panel to the Timeline 

panel, placing it just above the Background layer.

3 Choose Soft Light from the Mode menu for the Checkerboard layer in the 

Timeline panel.

� Tip: If you need 
to generate a 
checkerboard more 
quickly, use the 
Checkerboard effect. 
For more information, 
see After Effects Help.
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4 Lock the Checkerboard layer to ensure you don’t accidentally change it.

5 Save your work so far. 

Incorporating video and audio layers

The background is in place. Now you can add the video of the DJ and the audio 

track that accompanies it.

Adding audio and video files

You imported files at the beginning of the lesson. Now you’ll add them to the com-

position. The DJ.mov clip has no background and was rendered with a premultiplied 

alpha channel, so the underlying layers are visible. 

1 Press the Home key or drag the current-time indicator to the beginning of the 

composition.

2 Open the Assets folder in the Project panel, if it isn’t already open.

3 Drag the DJ.mov footage item to the Timeline panel, placing it above the  

other layers.

4 Drag the gc_adobe_dj.mp3 item from the Project panel to the Timeline panel, 

placing it beneath the other layers.

5 Lock the audio layer that you just added to the Timeline panel so that you can’t 

accidentally change it later. Then choose File > Save.

� Note: You can place 
an audio layer any- 
where in the layer stack, 
but moving it to the 
bottom keeps it out of 
the way while you work.
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Trimming the work area

The DJ.mov clip is only 5 seconds long, but the composition is 10 seconds. If you 

rendered this movie now, the DJ would disappear halfway through the movie. To 

fix the problem, you’ll move the work area end point to the 5-second mark. Then 

only the first 5 seconds will render.

1 Move the current-time indicator to the 5-second mark. You can drag the current-

time indicator in the Timeline panel, or click the Current Time box and then 

type 500. 

2 Press N to move the work area end point to the current time.

Applying a Cartoon effect

After Effects includes a Cartoon effect, which makes it easy to create a stylized look 

for your video. Since this intro for the DJ Quad Master reality series is very different 

from other reality series, the Cartoon effect will work perfectly here. 

1 Select the DJ.mov layer in the Timeline panel.

2 Choose Effect > Stylize > Cartoon.

The Cartoon effect performs three opera-

tions on a layer. First, it smooths the layer, 

removing a great deal of detail. Therefore, 

it works best on video footage rather than a 

graphic layer, such as the background in this 

project. Next, the Cartoon effect emphasizes 

the edges of shapes, based on their bright-

ness values. Finally, it simplifies the color  

in the layer. 

The default settings do a pretty good job, but you’ll fine-tune them in the Effect 

Controls panel. 

3 In the Effect Controls panel, choose Fill from the Render pop-up menu.

� Note: Alternatively, 
if you do not want 
to keep the last 
five seconds of the 
composition, you can 
change the duration 
of the composition to 
5 seconds. To do so, 
choose Composition > 
Composition Settings, 
and then type 5.00 in 
the Duration box.

� Tip: For interesting 
results, try changing the 
Cartoon Render options 
from Fill & Edges to Fill 
(for a color-only effect) 
or Edges (for black-and-
white line art).
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For this project, you’re selecting Fill only temporarily so that you can more easily 

see the results of the Fill settings as you make adjustments.

4 Change the Detail Radius amount to 20 and the Detail Threshold amount to 50. 

These settings control how much detail is removed and how it is smoothed. Higher 

values remove more detail.

5 In the Fill area, change the Shading Steps value to 10, and make sure the 

Shading Smoothness value is 70.

These settings determine how color is reduced and how gradients are preserved.  

In this project, changing these values reduces the number of colors in the DJ’s shirt, 

creating a simpler design.

6 Choose Edges from the Render pop-up menu so you can focus on the edge 

controls. The layer becomes black and white temporarily.

7 In the Edge area, change the Threshold to 1.25 and the Width to 1.

These settings reduce the number of black lines on the subject.

8 Leave the Softness value at its current setting (60), but lower the Opacity  

to 60% to make the lines more subtle.

9 Choose Fill & Edges from the Render pop-up menu to restore the color.

10 Expand Advanced to see the advanced controls, which give you precise control 

over the edges.
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11 Change the Edge Enhancement value to 50 to sharpen the edges of the layer.

12 Change the Edge Black Level to 2 to fill in more areas of the image with solid 

black. This makes the image even more cartoonish.

13 Lock the DJ.mov layer to ensure you don’t accidentally make changes to it as 

you continue the project.

Adding a title bar

You’ve created an exciting background and added the video of the DJ and the audio 

track. The only thing missing is the title to identify the program. You’ll use the 

Rectangle tool and path operations to create a dynamic shape, and then you’ll add 

the text.

Creating a self-animating shape

Wiggle Paths turns a standard rectangle into a series of jagged peaks and valleys. 

You’ll use it to create a shape that looks like a soundwave. Because the operation  

is self-animating, you need to change only a few properties for the entire shape  

to move on its own.

1 Select the Rectangle tool ( ), which is hidden beneath the Star tool ( ).

2 Click the Fill Color box, and select a light yellow. (We used R=255, G=255, 

B=130.) Click OK.

3 Click the word Stroke. In the Stroke Options dialog box, select Solid Color, and  

click OK.

4 Click the Stroke Color box, and select a light gray. (We used R=200, G=200, 

B=200.) Click OK.
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5 Change the Stroke Width to 10 pixels.

6 Draw a rectangle across the composition—near the bottom and approximately 

50 pixels high.

7 In the Timeline panel, expand Rectangle 1 > Rectangle Path 1. 

8 Unlink the Size values, and then change them to 680, 50.

9 Expand Stroke 1, and then change the Stroke Opacity to 30%.

10  Hide the Rectangle 1 properties.

11  Select Shape Layer 1, and choose Wiggle Paths from the Add pop-up menu.

12  Expand Wiggle Paths 1. Then change the Size to 150 and the Detail to 80.

13 Choose Smooth from the Points menu to make the path less jagged.

14  Change Wiggles/Second to 5 to speed up the movement.

15  Move the current-time indicator across the timeline to see the shape move. 

It’s not exactly an audio waveform, but it’s a stylistic version of one.

16  Hide all the properties for the layer. 

17  Rename the layer Lower Third, and then lock the layer.

� Tip: If you need 
to reposition the 
rectangle, use the 
Selection tool to drag 
it into place in the 
Composition panel.
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Adding text

All you need to do now is add the title of the program. You’ll use an animation 

preset to make the text stand out.

1 Press the Home key or move the current-time indicator to the beginning  

of the composition.

2 Select the Horizontal Type tool ( ). In the Character panel, select a sans serif 

font, such as Arial Bold or Helvetica Bold, and specify a size of 60 pixels.

3 Click the Fill Color box in the Character panel, and select black (R=0, G=0, B=0). 

Then click the Stroke Color box, and select white (R=255, G=255, B=255).

4 Change the Stroke Width to 2 pixels.

5 Click an insertion point in the Composition panel, and type DJ Quad Master. 

6 Select the Selection tool ( ), and then reposition the text over the wave- 

form shape.

7 Select the text in the Composition panel. In the Effects & Presets panel,  

type 3D Rotate In By Character in the Search box. Then drag the 3D Rotate  

In By Character animation preset onto the text.

After Effects applies the preset to the selected text.
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8 Make a RAM preview to see the movie so far. Press the spacebar to stop  

the preview. 

Using Brainstorm to experiment

The Brainstorm feature makes it easy to try different settings for effects, and to quickly 

apply the one you like. To use the Brainstorm feature, select the layer or properties 

you want to include, and then click the Brainstorm icon. The Brainstorm dialog box 

displays multiple variations of your image, based on randomized settings. You can 

save one or more of the variants, apply one to a composition, or redo the Brainstorm 

operation.

The Brainstorm feature works especially well with animation presets. You’ll use  

it to explore possibilities for the Suns layer you created for this project.

1 Save the project, and then choose File > Save As > Save A Copy. Name the copy 

of the project Brainstorm, and save it in the Lesson04/Finished_Project folder.

2 Unlock the Suns layer in the Timeline panel.

3 Click the Solo switches ( ) for the Suns and Background layers, so that you see 

only these two layers in the Composition panel.

You can isolate one or more layers for animating, previewing, or rendering by soloing. 

Soloing excludes all other layers of the same type from the Composition panel. 

� Note: With the 
Cartoon effect in place, 
the RAM preview 
may take longer than 
usual to render and 
begin playing.
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4 Expand the Suns layer, and then select Contents. 

5 Click the Brainstorm icon ( ) at the top of the Timeline panel to open the 

Brainstorm dialog box.

6 Select the level of randomness Brainstorm should apply to the layer properties. 

The default value is 25%; for drastic changes, try a higher number.

7 Click the Brainstorm button. The feature randomizes the properties and displays 

variants. You can click the Brainstorm button multiple times; each time, it ran-

domizes the settings by the percentage you’ve selected.

8 When you find a variation you like, move the pointer over the variant, and then 

click the check mark icon to apply it to the composition. 

9 If you don’t want to apply any of the variants, click Cancel to close the Brainstorm 

dialog box. Then unsolo the Suns and Background layers.

� Note: Selecting 
Contents selects all the 
properties for the layer, 
so that the Brainstorm 
feature includes them 
all in the operation. 
You can also use the 
Brainstorm feature 
to experiment with 
one or more specific 
properties.

� Tip: To return to a 
previous variation, click 
the Back button. To see 
all the variants in action, 
click the Play button. 
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Sidebar head

Sidebar Text

Extra credit 

Animating layers to match audio

Currently, the suns and stars move at their own pace. The movie will be more compelling if the 
checkerboard background is animated with the music. You can scale the diamonds that make  
up the background in time with the amplitude of the audio file. First, you need to create  
keyframes from the audio information.

1 Unlock the gc_adobe_dj.mp3 layer in the Timeline panel. Then right-click or Control-click  
the layer, and choose Keyframe Assistant > Convert Audio To Keyframes. 

After Effects adds the Audio Amplitude layer. The new layer is a null object layer, meaning it has  
no size or shape and won’t appear in a final render. Null objects let you parent layers or drive effects.

2 Select the Audio Amplitude layer, and choose Edit > Cut. 

3 Select the Checkerboard tab in the Timeline panel. Then choose Edit > Paste to paste the Audio 
Amplitude layer into that composition.

4 With the Audio Amplitude layer selected, press E to display the effects properties for the layer. 

Three categories of effects properties are available for the layer: Left Channel, Right Channel, and Both 
Channels. You need only the Both Channels properties, so you’ll delete the others.

5 Delete the Left Channel and Right Channel categories. Then expand the Both Channels category. 
Move the current time indicator across the timeline, and notice how the Slider value changes as 
you move across the keyframes.

When you converted the audio to keyframes, After Effects created keyframes that specify the 
amplitude of the audio file in each frame of the layer. You’ll sync the scale of the background  
to those values.

6 Select a light blue diamond in the Composition panel. Then press S to display its Scale property 
 in the Timeline panel. 

7 In the Timeline panel, Alt-click (Windows) or Option-click (Mac OS) the Scale stopwatch to add  
an expression. The words transform.scale appear in the time ruler for the layer. 

continues on next page
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Sidebar head

Sidebar Text

Extra credit (continued)

8 With the transform.scale expression selected in the time ruler, click the pick whip icon ( ) on  
the Expression:Scale line, and drag it to the Slider property name in the Audio Amplitude layer. 
You may need to expand the Timeline panel to see both the selected Light Blue layer and the 
Audio Amplitude layer, depending on which light blue layer you selected. If necessary, you can 
move the Audio Amplitude layer to a different position in the layer stack.

When you release the mouse, the pick whip snaps, and the expression in the solid layer time ruler  
now reads "temp = thisComp.layer("Audio Amplitude").effect("Both Channels")("Slider"); (temp,temp)" 
This means that the Scale values for the solid layer will depend on the Slider values of the Audio 
Amplitude layer.

Note: You’ll learn more about expressions in Lesson 6.

9 Choose Edit > Deselect All to deselect the layers. Then move the current time indicator through 
the time ruler to see the diamond resize with the audio’s amplitude. 

The scale definitely changes, but because the amplitude of the sound file isn’t very loud, the size  
of the layer remains small. You’ll modify the expression to increase the size of the diamond.

10 Select the expression for the Light Blue layer in the time ruler. Click an insertion point just before 
the semicolon, and type *2.5 to multiply the scale by 2.5. Then click outside the time ruler to 
accept the change. Now scrub through the time ruler to watch the diamond scale. 

11 Select the Scale property name for the Light Blue layer, and choose Edit > Copy to copy the 
property and expression.

12 Select all the other solid layers in the Timeline, and choose Edit > Paste so that all the diamonds 
will change scale with the music. Then scrub through the time ruler to see the results.

13 Click the Shapes Background tab in the Timeline panel to return to the main composition. Hide 
the Suns layer so the background isn’t quite so busy, and then make a RAM preview to watch the 
diamonds shrink and grow in time with the music.
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Review questions

1 What is a shape layer, and how do you create one? 

2 How can you quickly create multiple copies of a shape?

3 How can you snap one layer to another?

4 What does the Pucker & Bloat path operation do?

5 How does the Cartoon effect work?

Review answers

1 A shape layer is simply a layer that contains a vector graphic called a shape. To create 

a shape layer, draw a shape directly in the Composition panel using any of the drawing 

tools or the Pen tool. 

2 To quickly duplicate a shape multiple times, apply a Repeater operation to the shape 

layer. The Repeater path operation creates copies of all paths, strokes, and fills included 

in the layer.

3 To snap one layer to another in the Composition panel, select Snapping in the options 

section of the Tools panel. Then click next to the handle or point you want to use as 

a snapping feature, and drag the layer close to the point to which you want to align it. 

After Effects highlights the points to which it will align when you release the mouse 

button. Note that you cannot snap shape layers.

4 The Pucker & Bloat operation pulls the path’s vertices outward while curving segments 

inward (puckering), or pulls the vertices inward while curving segments outward 

(bloating). Negative values pucker a shape; positive values bloat it.

5 The Cartoon effect stylizes a layer by removing some details and emphasizing others, 

and by simplifying color. You can change settings in the Effect Controls panel to fine-

tune the effect’s behavior.
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3D axis  271

3D cameras  278–279
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camera layers  278
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Current Time button  135, 219
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installing  2

projects  10
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Adobe After Effects CC Classroom 

in a Book
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Adobe After Effects Help  36
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Adobe Bridge
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installing  2, 41
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Adobe Bridge (continued)

navigating folders in  41

opening  41

previewing audio files in  149

previewing images in  42

preview panel  42

workspaces  42

Adobe Certified Associate  6

Adobe Certified Expert  6

Adobe Certified Instructor  6

Adobe Illustrator files, importing  45

Adobe Media Encoder  365–370

creating presets for  368

output presets in  366

Adobe Photoshop files

importing  158

importing layer styles from  159

importing text from  71

layered  157

Adobe Premiere Pro, using with 

After Effects  230

aligning text  46

alpha track mattes

adjusting  168

using to constrain layers  132

ambient lights, adding  308

Analyze Forward button  332

anchor points, adjusting  129

animating

along a motion path  84

in time with audio  119

layers  154, 157

lighting  160, 171

motion  164

opacity  78, 282

Puppet tool pins  222

rotation  101

scale  68

shadows  172

slide shows  144

text  71, 60–89, 80, 242, 313

using parenting  69, 125

using the Puppet tools  213

walking cycles  218

animation presets  26–27

applying  49, 77

applying from Adobe Bridge  66

browsing in Adobe Bridge  41, 66

Bullet Train  50

customizing  67

Dissolve - Vapor  51

Evaporate  66

Fade Up Characters  74

Increase Tracking  77

Pipes  75

text  65, 68

using with shape layers  132

animations

about  24

copying to other elements  315

easing  69, 140

motion paths for  127

Warp Stabilizer VFX  324

animator properties in text animator 

groups  80

application window  11
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audio

adding tracks  149

editing files in Adobe 

Audition  152

file formats supported  149

layers  111

looping  150

using amplitude to animate 

layers  119

Audio/Video Switches in the 

Timeline panel  25

Audition. See Adobe Audition

Auto Levels effect  206, 258

Auto-Orient command  86

B

background, replacing  254–258

background strokes, creating  

with the Roto Brush 

tool  232–233

base frames

adding for the Roto Brush 

tool  235

creating with the Roto Brush 

tool  230–231

beveling text in Cinema 4D Lite  289

Bezier curves

breaking direction handles 

for  194

using to create masks  193

Bezier masks, creating  195

bicubic scaling  323

bilinear sampling  323

blending modes

about  202

applying  202

applying to shapes  101

for masks  192

Brainstorm feature  117

Bridge. See Adobe Bridge

brightness, changing in the user 

interface  35

broadcast, preparing a movie for  368

Browse Presets command  66

Bullet Train animation preset  50

C

C4D files  285

cached frames  234

cameras, adding to a 3D 

scene  278–279

Camera Settings  316

Cartoon effect  112

Casts Shadows property  277

CC Particle Systems II effect  338

properties  342

certification programs, Adobe  6

Channel Blur effect  29–30

Character panel  46, 63, 270

checkerboard, generating  110

child layers  70, 71, 125

Cinema 4D Lite  283–290

adding surface textures to objects 

in  290

coordinate measurements  283

creating 3D text in  285–287
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Cinema 4D Lite (continued)

exporting an After Effects 

composition for  284

positioning objects in  288

updating objects in After 

Effects  290

workspace  286

Cineware effect  285

Classroom in a Book  1

Clone Stamp tool  258

codecs  362

color

adjusting color balance  251

adjusting using the Photo Filter 

effect  263

correcting a range of colors  260

correcting with Auto Levels 

effect  206

keying  228

removing color casts  253

color correction  246, 258

about  248

Auto Levels  206

previewing accurately  250

Color Emboss effect  49

Color Finesse 3 effect  261

Color Range effect  254–256

Comp Camera option in the 

Cineware effect  285

Composition Navigator bar  26

Composition panel

about  14

splitting into multiple views  272

typing in  62

compositions

about  14

adding footage items to  16

changing the resolution of  131

creating  14, 43, 61, 145

defined  10

fitting layers to  44

importing  12

nesting  16, 110

rendering  53, 317

retiming  178

swapping into a layer  133

Composition Settings dialog 

box  43, 61

compression  362

Convert Audio To Keyframes  119

Convert To Editable Text 

command  26, 72

Convert Vertex tool  193, 194

coordinates

entering for effects  20

measured in After Effects and 

Cinema 4D Lite  283

copying animation to other 

elements  315

Corner Pin effect  172

Create Text And Camera  302, 303

creating

compositions  14, 61

shape layers  90, 328

text  46

current-time indicator  25

current time in the Timeline 

panel  25
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customizing

brightness of the user 

interface  35

preset paths  75

workspaces  35

Custom View 1  273

D

default preferences  2

Deform pins

about  214

adding  214

customizing  215

dependencies, finding missing  14

depth of field, adjusting  316

deselecting layers  17

direction handles, breaking  194

Dissolve - Vapor animation 

preset  51

distortions, rolling shutter  300

docking panels  11

drawing

circles  344

custom shapes  96

ellipses  204

polygons  97

rectangles  94

shapes  94

stars  102

tools  94

drift, in motion tracking  332

Drop Shadow effect  48

drop zone  11

duplicating

animations using pick whips  162

layers  18

shapes  104

duration  93, 128

about  27

E

Easy Ease  222

about  28

adding  28, 69, 140

adjusting  183

in the Graph Editor  351

Easy Ease Out  183

editing

a Premiere Pro clip in After 

Effects  230

a segmentation boundary  234

masks  192

text  72

Effect Controls panel  20

about  48

hiding properties in  21

setting properties in  20, 29–30

effects

about  18

applying  20, 47, 141

Auto Levels  206, 258

CC Particle Systems II  338

Channel Blur  29–30

Color Emboss  49

Color Range  254–255
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effects (continued)

controlling  47

Corner Pin  172

Dissolve - Vapor animation 

preset  51–52

Drop Shadow  48

Exposure  21

finding  19

Glow  243

Hue/Saturation  241

Lens Flare  174, 346

Matte Choker  256

missing  14

motion blur  87

Photo Filter  263

Radial Blur  19

Radio Waves  143

Ramp  345

Refine Hard Matte  239

Refine Soft Matte  239

SA Color Finesse 3  261

Stretch And Pitch, in 

Audition  152

Timewarp  348

Zoom-Bubble  27

Effects & Presets panel  19, 27

Ellipse tool  204, 344

using to create a mask  205

end bracket, setting for the work 

area  66

erasing unwanted elements  258

Evaporate animation preset  66

Expand Or Collapse The In/Out/

Duration/Stretch Panes 

button  142

exporting

for Cinema 4D  284

movies with Adobe Media 

Encoder  365

Exposure effect  21

expressions  120

about  162

adding  150

applying  162

working with  150

Extrude NURBS in Cinema 4D 

Lite  288

extruding text

in After Effects  293

in Cinema 4D Lite  288–289

F

Fade Up Characters animation 

preset  74

fading in images  148

feathering masks  200

Fill Color  98

Fill Options dialog box  98

fills, gradient  95

finding missing footage, fonts, or 

effects  14

FireWire  250

First Margin value  86

Fit To Comp command  44

Fit To Comp Width command  64
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fonts

finding missing  14

selecting  63

footage

about  12

finding missing  14

importing  10, 13, 60, 157

importing using Adobe  

Bridge  41

interpreting in After Effects  190

tracking  301

foreground strokes, 

creating  231–232

freezing Roto Brush tool  

results  239

G

Glow effect  243

Gradient Editor  95

gradient fills  95

modifying  96

Graph Editor

about  180

in the Timeline panel  25

using to remap time  181, 351

grids

displaying  47, 64

hiding  47, 65

snapping to  64

ground planes, creating with 3D 

Camera Tracker effect  302

H

HDR (high dynamic range) 

footage  348

hiding properties  21

Home key  27

Horizontal Type tool  26, 46, 77

Hue/Saturation effect  241

HyperNURBS icon in Cinema 4D 

Lite  288

I

IEEE 1394  250

importing

files from Adobe Bridge  42

footage  10, 13, 41, 60, 157

multiple files  12

Photoshop files  12, 71, 158

text  71–72

Increase Tracking animation 

preset  77

Increment And Save 

command  241–242

In point  25, 128

installing After Effects  2

interpolation between keyframes  28

Interpret Footage dialog box  190

In value for a layer  142

inverting masks  192

J

JavaScript in expressions  162
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K

keyframes

about  28

adding to current time  219

copying from one layer to 

another  140

creating from audio 

amplitude  119

roving  222

keyframing motion paths  134

keying  228, 254–255

L

layer features, used when 

snapping  109

layers

about  14, 16

adjustment layers  263

animating  154, 157

animating to match audio  119

audio  111

child  70, 71

converting to 3D layers  273

copying keyframes from  140

deselecting  17

duplicating  18

expanding in the Timeline 

panel  22

fitting to compositions  44

importing in Photoshop files  157

light, 3D  274–276

making visible in the Timeline 

panel  31

modifying the In values for  142

naming in Photoshop  158

naming text layers  47

nesting  50

null  311

parent  70, 71

precomposing  50, 168

rearranging in the Timeline 

panel  17

renaming  18, 73

scaling  212

shape  90, 94

snapping  106

solid  107, 141

soloing  161

text  62

transforming properties  22

trimming  128

video  111

viewing multiple properties  221

layer styles  159

Layer switches in the Timeline 

panel  25

learning resources for Adobe After 

Effects CC  5

Lens Flare effect  174, 346

lesson files, downloading  3

Levels (Individual Controls) 

effect  252

lighting, simulating changes in  160

lights

adding to a 3D scene  274–276

ambient  308

point  307
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Light Settings dialog box  275

linking animations through 

expressions  162

looping audio tracks  150

M

Magnification Ratio pop-up 

menu  94

Mask Feather tool  200

masks

about  188

creating Bezier  193, 195

creating with the Pen tool  191

curved  193

drawing with the Ellipse  

tool  205

drawing with the Rectangle 

tool  205

editing  192

inverting  192

layers  132

modes for  192

modifying with the Convert 

Vertex tool  193

properties, displaying  192

replacing content of  197

segments  188

tips for creating  206

using alpha mattes in  132

using vector shapes  130

vertices  188

working with  186

mask shapes, copying  85

Master Exposure (Exposure 

effect)  21

Material Options properties   

271, 277

Matte Choker effect  256

mattes

about  228

adjusting with the Refine Edge 

tool  238

track  169

traveling  169

viewing against black  233

viewing with red overlay  233

Maxon Cinema 4D Exporter  284

Maxon Cinema 4D Lite  283–290

meshes

adjusting the Triangle value  216

used with Puppet tools  214

missing fonts, effects, or  

footage  14

mobile devices, preparing 

compositions for  364

mocha for After Effects  337

modes, mask  192

motion

animating  164

stabilization  322

motion blur

adding  87, 128, 136, 170

motion paths

about  135

animating nontext layers 

along  84

hiding  31
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motion paths (continued)

keyframing  134

viewing in the Composition 

panel  127

Motion Source  330

Motion Target  330

motion tracking

analyzing and applying  332, 336

drift  332

multipoint  333

single-point  327

N

navigating folders in Adobe 

Bridge  41

nesting

compositions  16, 110

layers  50

NTSC D1 preset  43

null objects  283, 311

O

opacity

animating  78, 148, 282

modifying  23, 52

optimizing performance in After 

Effects  2, 33

Orient Along Path option  86

Out point  25, 128

output modules in the Render Queue 

panel  54

output presets in Adobe Media 

Encoder  366

outputting projects  354

overlap, defining areas of  216

Overlap pins

about  214

customizing  217

overscan, accounting for  30

P

panels

docking and arranging  11

groups  11

maximizing  10

menus  25

Paragraph panel  46, 63

paragraph text  62

parallel corner-pinning  333

parenting  69, 125

object to null layer  312

text in Cinema 4D Lite  288

parent layers  125

about  70, 71

animating  126

creating  134

particle systems

creating  338–339

customizing  340

path preset, using to animate  

text  75

Pen tool  191

performance, optimizing  2, 33

perspective corner-pinning  333
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Photo Filter effect  263

Photoshop. See Adobe Photoshop 

files

pick whip  312

using to duplicate animation  162

Pipes animation preset  75

pixel aspect ratio  368

point light, creating  307

point of interest

for a 3D light  275

for a camera layer  279

point text  62

polygons, drawing  97

Polygon tool  97

Polystar properties  97, 101

Position property

displaying in the Timeline 

panel  22

for a 3D layer  197

Pre-compose dialog box  51

precomposing layers  50, 51, 168

preferences, restoring defaults   

2, 10, 40, 60, 92, 124

Premiere Pro. See Adobe  

Premiere Pro

preset paths, customizing  75

presets

browsing in Adobe Bridge  66

creating for Adobe Media 

Encoder  368

finding  19

previewing

audio files in Adobe Bridge  149

compositions  30, 53

images in Adobe Bridge  42

limiting to a range of frames  66

manual  50

RAM  32

spacebar  31

standard  31

Preview panel in Adobe Bridge  42

Project panel  13

projects

about  10

saving  14

properties

changing values for multiple 

layers  23

displaying in the Timeline 

panel  22

Pucker & Bloat  103

Puppet Overlap tool

about  214

using  216

Puppet Pin tool  214

Puppet Sketch tool  222

Puppet Starch tool

about  214

using  217

Puppet tools  208

about  214

customizing Overlap pins  217

preparing artwork for use 

with  213

Puppet Sketch tool  222

recording animation with  222

settings for Starch pins  217

using the mesh  214
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Q

QuickTime  2

R

Radial Blur effect  19

Radial Gradient option  95

Radio Waves effect  143

Ramp effect  345

RAM previews  32

Ray-Traced 3D Renderer  293

Rectangle tool  94, 205

red overlay in matte preview  233

Reduce Chatter value  238

Refine Edge tool  238–239

Refine Hard Matte effect  239

Refine Soft Matte effect  239

remap-time marker in the Source 

Time ruler  179

removing unwanted elements   

258–260

renaming layers  18

Renderer options in the Cineware 

effect  285

rendering  317

compositions  53

for mobile devices  364

movies  354

templates  357

test movies  361

using compression in  362

using the Render Queue 

panel  244, 362

with Adobe Media 

Encoder  365–370

Render Queue panel  54, 177, 244, 

357–364

adding compositions to  54

opening  54

Render Settings options  54

render-settings templates  357

Repeaters  99, 104

replacing content using a mask  197

resizing layers  212

resources for using After Effects  36

restoring default preferences  10, 40, 60

retiming

compositions  178

playback  348

rolling shutter distortions, 

repairing  300

rotating

3D layers  198

shapes  101, 105

Rotation property, animating  101

Roto Brush & Refine Edge  

effect  237

Roto Brush tool  226–245

creating background strokes 

with  232–233

creating foreground strokes 

with  231–232

freezing results  239

refining a segmentation 

boundary  234

rotoscoping  228

Roving keyframes  222
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S

SA Color Finesse 3 effect  262

safe zones  30

sampling algorithms  323

saving projects  14

scaling layers  212

scrubbing to select values  20

segmentation boundary

about  230

creating  230–233

refining  234

segments in a mask  188

selectors in text animator groups  80

Select View Layout pop-up 

menu  272

separating background from 

foreground  228–245

shadow catcher  308

shadows

adding to a 3D scene  277

creating with the 3D Camera 

Tracker effect  306

shape layers

about  90, 92

adding  94

applying gradient fills to  95

creating  132, 328

using animation presets with  132

shapes

about  94

applying Repeaters to  104

drawing  94, 96

duplicating  104

repeating  99

rotating  101, 105

twisting  98

using as masks  130

shortcuts for Transform 

properties  22

shortening

layers  128

movies  112

Shutter Angle

about  171

adjusting  171

Shutter Phase  171

skewing text  81

slide shows  144

smoothing animations with Easy 

Ease  28

snapping

features  109

layers  106–110

limitations  109

Snapping option

about  109

temporarily enabling  109

Snap to Grid command  64

solid layers

about  141

creating  107, 141

using to create particle 

systems  339

soloing layers  161

Source Time ruler in time 

remapping  179

spacebar preview  31



ADOBE AFTER EFFECTS CC CLASSROOM IN A BOOK 385

span, extending for Roto Brush 

tool  234

Specular Intensity  277

Specular Shininess  277

splitting the Composition panel into 

multiple views  272

squash and stretch animation  218

stabilizing motion  322

standard preview  31

Starch pins

about  214

adding  217

settings  217

stars

creating  102

modifying settings for  102

Star tool  102

Stretch And Pitch effect, in 

Audition  152

Stroke Color  98

Stroke Options dialog box  103

Stroke Width  98

surface, adding to objects in Cinema 

4D Lite  290

synchronizing audio with 

animation  119

T

templates for rendering  357

text

adding  116

adding a bevel in Cinema 4D 

Lite  289

animating  71, 60–89, 74, 80, 

242, 313

animating tracking in  77

animating using a path preset  75

animation presets for  26–27, 65

centering  270

converting to editable  72

creating  46

creating 3D  269–271

creating 3D in Cinema 4D 

Lite  285–287

editing  72

entering in the Composition 

panel  62

extruding in After Effects  293

extruding in Cinema 4D Lite  288

formatting  63, 116, 242

formatting in Cinema 4D 

Lite  287

imported from Photoshop  71

layers  62

naming layers  47

point  62

positioning  64

skewing  81

text animator groups  79

Text tool in Cinema 4D Lite  287

time

current-time field  25

current-time indicator  25

duration  27

measuring  219

specifying in the Duration box  93

timecode  27
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time graph  25

time-lapse simulation, creating  178

Timeline panel

about  25

displaying properties in  22, 23

expanding layers in  22

renaming layers in  73

viewing multiple layer properties 

in  221

Time Remap keyframes  181

Time Remapping  150, 178

Time-Reverse Keyframes 

command  67

time ruler

about  25

in the Timeline panel  25

Time Stretch dialog box  142

Timewarp effect  348

title-safe zones  30

Toggle Alpha Boundary button  233

Toggle Alpha button  233

Toggle Alpha Overlay button  233

Toggle Switches/Modes button  132

Toggle Transparency Grid 

button  240

tools

Clone Stamp  259

Mask Feather  200

Puppet  214

Tools panel

about  17

selecting hidden tools in  17

Track Camera command  301

tracking

animating for text  77

using Mocha for After Effects  337

tracking motion

multipoint  333

single-point  327

using the 3D Camera Tracker  301

tracking presets

customizing  78

using to animate text  77

track mattes

about  169

creating  168, 169

track points

3D Camera Tracker  301

moving and resizing  331

positioning  329, 335

Transform properties  22

transparency  52

traveling mattes  169

Triangle value for Puppet tools  216

trimming

layers  128

the work area  112

TrkMat menu  132

twisting shapes  98

Twist path operation  98

U

undocking panels  11

User Interface Colors  35
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V

vector shapes, masking with  130

vertices

converting  193

in a mask  188

video layers  111

Video Preview  250

Video switch  31, 52

views, 3D  272

vignette, applying  204

W

walking cycle, animating  218

Warp Stabilizer VFX  322–327

settings  325, 327

work area

brackets  25, 66

trimming  112

workflow  10

workspaces

customizing  11

in Adobe Bridge  42

predefined  34

saving custom  35

X

x axis  20

in the 3D axis  271

Y

y axis  20

in the 3D axis  271

Z

z axis  269

in the 3D axis  271

Zoom-Bubble effect  27
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